RB "0% failure rate"

  • Dark Theme is now available. Switch at the bottom of the page or in your preferences.

veer90

Lieutenant
Nov 16, 2016
590
West Nyack, NY
#1
Just because I'm tired of Rob's passive-aggressive shitposting as of late, have some time on my hands, and am feeling extremely petty.

How's that "0% failure rate" you always post about working out for ya, Rob?

Do3DaLM.jpg

5rZ7ewL.jpg
 

Milan

Corporal
Dec 24, 2016
127
jebi se
#2
So your sample size is 1? I believe he said in the last couple years, not for all eternity.

I give your troll attempt 1/10
 

veer90

Lieutenant
Nov 16, 2016
590
West Nyack, NY
#3
This isn't meant to be a troll post. Next time I see Rob being an annoying, passive aggressive little shit or making bullshit claims in another vendor's thread, I'll simply drop the link here for everyone to see.
 

[email protected]

Sergeant
Platinum Vendor
Oct 19, 2016
364
NY & AZ
#4
doesnt look like a failure due to manufacturing.. looks like motor blew and turbo ingested shrapnel of some sort.
 

fmorelli

Moderator
Aug 11, 2017
1,618
Virginia
#5
That's the problem with the Internet - who really knows what the story is. Given the BS I see on the Facebook group that gets posted, I'd be remiss to have products installed on half these people's cars. My reputation by proxy of idiot owners - not a winning strategy.

Filippo
 
Nov 5, 2016
116
SC
#6
If you care to read RB's stats thread he clearly states failures in the past 18 months. He definitely does not claim he has a zero failure rate since he has been producing turbos. I will admit I had doubts when he first posted the stats. I saw a member in a local bmw group post that he bought a 135 and the RBs ones had failed right after purchase. Within a week Rob had updated the thread reporting about the failure. As for the picture you posted they are a set of RB classics that have not been made in a long time. The person selling them said he bought the car with them installed and put 30K+ miles on them since he purchased them.
 

veer90

Lieutenant
Nov 16, 2016
590
West Nyack, NY
#7
doesnt look like a failure due to manufacturing.. looks like motor blew and turbo ingested shrapnel of some sort.
Motor doesn't have to blow for a badly cast turbine wheel to toss a fin when run too hard. Or in the case of Vargas turbos when you look at them wrong.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top